PHP agent compatibility


The PHP agent is compatible with the most popular web frameworks, operating systems and web servers. Below you can find more details about specific version compatibility.

Refer to the installation steps to install Sqreen in your PHP applications.

Other framework?

We are working on supporting more frameworks. Please, contact us if you are using a different framework. We are happy to revisit our roadmap!

PHP versions

The Sqreen PHP agent is fully compatible with:

  • PHP 5.3
  • PHP 5.4
  • PHP 5.5
  • PHP 5.6
  • PHP 7.0
  • PHP 7.1
  • PHP 7.2
  • PHP 7.3

PHP frameworks

The Sqreen PHP agent is independent of your app's framework. It works with Laravel, Symfony, Zend, Codeigniter and more.

Operating systems

Sqreen supports the PHP agent on 64-bit versions of:

  • Debian 7, 8 and 9
  • Ubuntu >= 14.04
  • Enterprise Linux 7 (RedHat, CentOS, Amazon Linux)
  • Alpine Linux >= 1.1.0

Databases

Sqreen protects against SQL and NoSQL injections for the most common production databases:

Other database?

Contact us if you are using a different database. We are happy to revisit our roadmap!

Automatic user context in PHP

Sqreen can't automatically detect the user context in PHP. Read the SDK for user monitoring guide to learn how to integrate the SDK.

New Relic

The Sqreen PHP agent is fully compatible with the New Relic APM solution. We recommend loading Sqreen after New Relic for the Sqreen instrumentation to behave as expected.

Blackfire by Sensiolabs

The Sqreen PHP agent is fully compatible with the Blackfire APM solution by Sensiolabs. We recommend loading Sqreen after Blackfire for the Sqreen instrumentation to behave as expected.

Hack support

We plan support for the Hack language in a future release.

Looking for Hack support?

Please, contact us if you are using Hack. We are happy to revisit our roadmap!